GT784WN Firmware Upgrade NCS01-1.0.14

This Firmware upgrade resolves issues with enabling and disabling the WPS feature.

NOTES:

Be sure to make note of any custom settings before upgrading your unit.

Mac users using Safari may need to disable the 'Open 'safe' files after downloading' option before downloading this file.

Actiontec Electronics will not provide a refund or replacement, for products that have failed due to the loading of incorrect firmware or the testing of custom firmware.

(To identify your Actiontec product, look for the model number. It is located on the FCC sticker, found on the bottom or back of the product. Typically the model number is in the sticker's upper right-hand corner.)

This Firmware Upgrade (NCS01-1.0.14) is for the GT784WN ONLY. It is not to be used on any other model of router or gateway. This is an NCS (Non-Customer Specific) Firmware and is not intended as an Upgrade for ANY ISP Specific Firmware, regardless of version number. Therefore, you should not load an NCS Firmware Upgrade on to a gateway that currently has an ISP Specific Firmware installed. The reverse is also true. You should not load an ISP Specific Firmware Upgrade on to a gateway that currently has an NCS version installed. These types of Upgrades frequently result in a nonfunctional device.

Clicking the link below will initiate the download, and at the prompt 'Do you want to run or save this file?' select 'Save'. At the following 'Save As' dialog, be sure to select a familiar location to save the file, like 'My Documents' or the 'Desktop', so that the file will be easy to find later.

NOTE: If you get an error that the image is corrupt or invalid you are trying to open the image instead of following the upgrade instructions. The image file is not corrupt.

Was this article helpful?
15 out of 38 found this helpful

Comments

111 comments
  • I purchased my GT784WN October 11, 2017 and it worked okay until about a month ago when it started disconnecting from Centurylink DSL. The disconnects became more frequent, until finally even a hard reset did not clear it. Centurylink sent a technician out today, who tested the line and said it was fine, the modem was at fault. Prior to this it had had a flashing DSL light and no internet light for two days. I had hard reset it several times. Since I had to have internet for work, I bought a new modem from the tech and he set it up and now I can work. I would have been down for two more days at least if I had to order another modem from you. What I want to know is if you will refund the purchase price under your warranty, because I do not need a replacement modem now.

    0
    Comment actions Permalink
  • Sorry if I'm missing the obvious, but where is the zip file located for download? I see the instruction PDF, but not the actual firmware file.

    0
    Comment actions Permalink
  • Yes, I did and everything is find there. It is not my DSL.

    0
    Comment actions Permalink
  • Hello? Been a few days since I asked. Same issue as Thomas - any solution for us? random inteGT784WN issue but rather a POS company called frontier who oversold the sockets available in our area and they must kick some of us off for new people to get on line... please reply with your thoughts.

    0
    Comment actions Permalink
  • Kathy,

    In your case and taking into consideration the age of the unit, I would replace the GT. Get a hold of your ISP and see what model they recommend you purchase.

    0
    Comment actions Permalink
  • Arden,

    We have uploaded a new firmware file that is a bit larger in size when unzipped. Please try that one.

    0
    Comment actions Permalink
  • I have a Model GT784WN.

    0
    Comment actions Permalink
  • Carl,

    I have downloaded the file on two different computers and did not experience an issue. What are you doing when you get the error that you described above? Please make sure you are unzipping the file before you attempt the upgrade. The file that you should be using for the upgrade should end in .img not .zip.

    0
    Comment actions Permalink
  • Not sure if Admin will leave this comment up, but if so... Kathy, concider NOT buying your ISPs recomended brand but instead by a GOOD one. Higly recommended to is IQrouter (google it & google IQrouter GT784 to see discussions using together to fix the lockups and slowness) - keep your GT784wn but shut off the problem wifi that causes it to lock up, and set DMZ zone to just pass ALL traffick to the new smart IQrouter that will actually optimize your ISP phone line.

    0
    Comment actions Permalink
  • Josh,

    This appears to be a 5-year-old bug that has been brought up again. But thank you for your message and bringing this to our attention. The Broadcom chipset in our products does not use the libupnp which has caused all of the concern you mentioned. Instead, Broadcom uses their own UPnP stack which is not exposed. Again, thanks for taking the time to bring this to our attention.

    0
    Comment actions Permalink
  • Reese,

    The first question is did you unzip the file?

    0
    Comment actions Permalink
  • i have the same issues as everyone..internet light goes off then after reboot comes back on for a little

    0
    Comment actions Permalink
  • Using a GT784WN router through CenturyLink in Kingston WA. My internet has been extremely slow, often really non-functional CenturyLink seems unable to correct this except to have me disconnect power, wait, reconnect, which works for a while. Last support person suggested that fault might be with the router. Your thoughts? This upgrade something I should do?

    0
    Comment actions Permalink
  • August 2012, from CenturyLink

    0
    Comment actions Permalink
  • Mark,

    You need to find a program that can unzip a zip file. then you can follow the instructions provided. The file will not open automatically even on a windows computer.

    0
    Comment actions Permalink
  • Chrome Beta 69.0.3497.53

    Also, perhaps the link should go to a dedicated page to prevent confusion in the future?

    0
    Comment actions Permalink
  • Experienced intermittent drops in connectivity. Called my ISP to confirm I had the setup correct. Kept having problems. As recommended on this page, I upgraded to the most recent firmware. Got the "update successfully applied message", but never got any functionality after that. Power light was solid red. Waited about 5 minutes. Tried cycling the power, then tried pressing and holding the reset button. Still a solid red light. Accessing through the browser got no response or connection. Then I called customer service and waiting forever only to speak to someone with such a strong accent I could barely understand them. After about 30 minutes on the phone with them, yup - the modem is fried (which I could have told you before I called). Now have to get a replacement. So thank you for all your expert advice and what a wonderfully lousy product it is.

    0
    Comment actions Permalink
  • I am sending the info via the email that you sent to me earlier with screen shots of the current status and system setup settings

    0
    Comment actions Permalink
  • I downloaded the zip file for the upgrade. However after extracting (or even just going into the zip folder) and clicking on the image file, I get an error message that says the disk image file is corrupt and cannot be mounted.

    0
    Comment actions Permalink
  • I cannot find a status page in my modem that shows these values; how do I check these values?

    -1
    Comment actions Permalink
  • Martin,

    The file has been updated.

    -1
    Comment actions Permalink

Please sign in to leave a comment.